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1. Before you start 
1.1. About this manual 

The documentation for your software consists of two parts: the online help and 
this manual.  
In the manual, you will find both an introduction to the product and an explanation 
of the user interface. By using the extensive step-by-step instructions you can 
quickly learn the most important procedures for using this software. 
In the online help, you will find detailed help for your software.  
In this documentation, the term "your software" will be used for labSens. 
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1.2. What is labSens? 
labSens is a software used for microscopy in laboratory environments and in a 
pathological routine environment. It supports various kinds of hardware such as 
digital cameras and motorized microscopes and stages.  
The main functions of labSens ensure quick and handy workflows for the 
following tasks: 

 Controlling digital cameras 
 Acquiring images 
 Annotating images 
 Measuring images 

 
There are additional software solutions available for labSens offering enhanced 
functionality. 

 NetCam 
NetCam enables the user to transmit/stream a live image via a web 
server to browser based clients. 

 Patho 
The Patho solution extends the workflow and enables the case wizard. 
This package contains a dedicated database system. The Patho solution 
guides the users through image acquisition and allows them to save all 
acquired images by case and slide in dedicated folders in the database. 
 
 

The labSens tool window guides users during image acquisition and helps to 
store all acquired images by case and slide.  
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2. Working with labSens 
2.1. User interface 

The graphical user interface determines your software's appearance. It specifies 
which menus there are, how the individual functions can be called up, how and 
where data, e.g. images, is displayed, and much more. Here, the basic elements 
of the user interface are described. 
Appearance of the user interface  

 
The illustration shows the schematic user interface with its basic elements.  
You can call up many commands by using the corresponding menu. Your 
software's menu bar can be configured to suit your requirements. Use the Tools 
> Customization > Start Customize Mode... command to add menus, modify, or 
delete them.  
Further information is available in the online help. 
The document group contains all loaded images.  
When you start your software, the document group is empty. While you use your 
software, it gets filled - e.g., when you load or acquire images, or perform various 
image processing operations to change the source image and create a new one. 
Commands you use frequently are linked to a button providing you with quick 
and easy access to these functions. Please note that there are many functions 
which are only accessible via a toolbar, e.g., the drawing functions required for 
annotating an image. Use the Tools > Customization > Start Customize Mode... 
command to modify a toolbar's appearance to suit your requirements. 
Tool windows combine functions into groups. These may be very different 
functions. For example, in the Properties tool window you will find all the 
information available on the active document.  
In contrast to dialog boxes, tool windows remain visible on the user interface as 
long as they are switched on. That gives you access to the settings in the tool 
windows at any time. 

(1) Menu bar 

(2) Document 
group 

(3) Toolbars  

(4) Tool windows 
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The status bar shows a lot of information, e.g., a brief description of each 
function. Simply move the mouse pointer over the command or button for this 
information.  
Further information is available in the online help. 
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2.2. Layout 

Overview - Layouts 
To switch backwards and forwards between different layouts, click the name of 
the layout you want in the menu bar, or use the View > Layout command. 
Please note: There is usually only one layout available in your software version. 
A description of this layout can be found in the online help. If only one layout is 
available, the name of the layout is not displayed in the menu bar. 
If you received the "Patho" solution with your software, the following layouts are 
available: 

 Acquire images ("Acquisition" layout)  
 Manage records and measurements ("Review" layout) 
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What is a layout? 
The user interface is configurable, so that you can easily adapt it to meet the 
requirements of individual users or tasks. You can choose a so-called "layout" 
that is suitable for the task on hand. A "layout" is an arrangement of the control 
elements on your monitor that is optimal for the task at hand. In any layout, only 
the software functions that are important in respect to this layout will be available. 
Please note: There is usually only one layout available in your software version. 

(5) Status bar 
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Which elements of the user interface belong to the layout? 

 
The illustration shows you the elements of the user interface that belong to the 
layout.  

 (1) Toolbars 
 (2) Tool windows 
 (3) Status bar  

Activating a layout 
Please note: There is usually only one layout available in your software version. 
For this reason, you can't activate any other layouts and no other layouts are 
displayed in your menu bar. 
There are several ways in which you can activate a layout. 

1. Use the View > Layout command to open a menu containing all of the 
available layouts. Select the layout you want from this menu.  

2. You will find a tab for each layout at the top right corner of the user 
interface. Click the name of the desired layout (1). 

 
3. For each layout, you will find the Layout (2) button next to the tabs 

located to the right side of the menu bar. Click this button to open a 
menu with all of the available layouts. Select the layout you want from 
this menu.  

Editing layouts 
You can change a layout at any time. Use the commands in the View menu to 
have the user interface's individual elements shown or hidden.  
You have not only the possibilities of hiding or showing the user interface's 
elements and changing their size and position. As well as that, you can also 
change existing toolbars, or even set up your own. These changes will not be 
saved in the layout, but instead, in the configuration. They will remain available to 
you, even when you return the layout to its standard form. 
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Saving and resetting layouts 
Changes made in layouts will be automatically saved. Use the View > Layout > 
Reset Current Layout command to reset the layouts to their default configuration. 
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2.3. Document group 
The document group contains all loaded documents.  

  
On the left, the illustration shows a schematic representation of a user interface. 
On the right, the document group is shown enlarged.  

(1) Document group in the user interface 
You will find the document group in the middle of the user interface. In it you will 
find all of the documents that have been loaded or acquired. Also the live-image 
and the images resulting from, e.g., any image processing function, will be 
displayed there.  

(2) Document bar in the document group 
The document bar is the document group's header.  

 
For every loaded document, an individual field will be set up in the document 
group. Click the name of a document in the document bar to have this document 
displayed in the document group. The name of the active document will be 
shown in color. Each type of document is identified by its own icon. 

(3) Buttons in the document bar 
At the top right of the document bar you will see several buttons. 

 
Click the button with a hand on it to extract the document group from the user 
interface. In this way you will create a document window that you can freely 
position or change in size.  
If you would like to merge two document groups, click the button with the hand in 
one of the two document groups. While pressing the left mouse button, drag the 
document group with all the files loaded in it, onto an existing one.  

 
 
 

Appearance of the 
user interface 

Button with a hand 
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You can only position document groups as you wish when you are in expert 
mode. In standard mode the button with the hand is not available. 
The arrow buttons located at the top right of the document group are, to begin 
with, inactive when you start your software. The arrow buttons will only become 
active when you have loaded so many documents that all of their names can no 
longer be displayed in the document group. Then you can click one of the two 
arrows to make the fields with the document names scroll to the left or the right. 
That will enable you to see the documents that were previously not shown.  
Click the button with a cross to close the active document. If it has not yet been 
saved, the Unsaved Documents dialog box will open. You can then decide 
whether or not you still need the data.  

(4) Navigation bar in the image window 
Some images have their own navigation bar directly in the image window. Use 
this navigation bar, e.g., to specify how a Z-stack is to be displayed on your 
monitor, or to change this. 
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2.4. Tool Windows 
Tool windows combine functions into groups. These may be very different 
functions. For example, in the Properties tool window you will find all the 
information available on the active document.  

Position of the tool windows 
The user interface is to a large degree configurable. For this reason, tool 
windows can be docked, freely positioned, or integrated in document groups. 
Tool windows can be docked to the left or right of the document window, or 
below it. To save space, several tool windows may lie on top of each other. They 
are then arranged as tabs. In this case, activate the required tool window by 
clicking the title of the corresponding tab below the window. 

 
You can only position tool windows as you wish when you are in expert mode. 
You can set a tool window to float at any time. The tool window then behaves 
exactly the way a dialog box does. To release a tool window from its docked 
position, click on its header with your left mouse button. Then while pressing the 
left mouse button, drag the tool window to wherever you want it. 

Buttons in the header 
In the header of every tool window, you will find the three buttons Help, Auto 
Hide and Close. 

Arrow button 

Button with a cross 

Docked tool 
windows 

Freely positioned 
tool windows  
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Click the Help button to open the online help for the tool window. 
Click the Auto Hide button to minimize the tool window. 
Click the Close button to hide the tool window. You can make it reappear at any 
time, by using the View > Tool Windows command. 

Context menu of the header 
To open a context menu, rightclick a tool window's header. The context menu 
can contain the Auto Hide and Transparency commands. Which commands will 
be shown, depends on the tool window.  
Additionally, the context menu contains a list of all of the tool windows that are 
available. Every tool window is identified by its own icon. The icons of the 
currently displayed tool windows will appear clicked. You can recognize this 
status by the icon's background color.  
Use this list to make tool windows appear.  
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2.5. Working with documents 
You can choose from a number of possibilities when you want to open, save, or 
close documents.  
Please note: Your software version supports only documents belonging to the 
document type "Image". Thus, the term "Documents" means "Images" in this 
manual.  
You can recognize documents that have not been saved by the star icon after the 
document's name. 
There are a number of ways to save documents.  

1. Save your documents in a database. That enables you to store all 
manner of data that belongs together in one location. Search and filter 
functions make it quick and easy to locate saved documents. Detailed 
information on inserting documents into a database can be found in the 
online help. 
A database is only available if you have the "Patho" solution for your 
software. 

2. To save a single document, activate the document in the document 
group and use the File > Save As... command.  

3. Use the Gallery tool window. 
Select the desired document and use the Save command in the context 
menu. For the selection of documents, the standard MS-Windows 
conventions for multiple selection are valid.  
 

1. If you have purchased the "Patho" solution with your software, you have 
a database available to you.  
In the labSens  tool window, the workflow is then organized as a series of 
cases for you to work on. First, click the Start Case button and perform 
all of the image acquisitions, annotations and measurements necessary 
for this case. The images are automatically saved in the database.  

Saving documents 

Autosave and 
close 
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2. When you exit the software, all of the data that has not yet been saved 
will be listed in the Unsaved Documents dialog box. This gives you the 
chance to decide which documents you still want to save. 

3. With some acquisition processes, the acquired images will be 
automatically saved after the acquisition has finished. You will find an 
overview of the acquisition processes that are supported in the online 
help.  

4. You can also configure your software in such a way that all images are 
saved automatically after image acquisition. To do so, use the 
Acquisition Settings > Saving dialog box.  
 

There are a number of ways to close documents.  
1. To close a single document, activate the document in the document 

group and use the File > Close command. Alternatively, you can click the 
button with the cross . You will find this button on the top right in the 
document group. 

2. Use the Gallery tool window.  
Select the desired document and use the Close command in the context 
menu. For the selection of documents, the standard MS-Windows 
conventions for multiple selection are valid.  
 

There are a number of ways to open or load documents.  
1. Use the File > Open... command. 
2. Use the File Explorer tool window.  
3. Drag the document you want directly out of the MS-Window plorer, 

onto your software's document group. 
4. To load documents out of a database into the document group, use the 

Load Documents command. 
00143 
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